[RoR] install

RoR이라는게 있다는걸 알고나서 도~전~

(주의: 여긴 기획자 블로그라서 질문해도 모릅니다; 태글거셔도 대응불가임 -ㅅ-)

참고 중인 RoR 튜토리얼

<pre>
[[email protected]:~]$rvm install 1.9.3
mkdir: cannot create directory `/usr/share/ruby-rvm/gems/ruby-1.9.3': Permission denied
mkdir: cannot create directory `/usr/share/ruby-rvm/log/ruby-1.9.3': Permission denied
Installing Ruby from source to: /usr/share/ruby-rvm/rubies/ruby-1.9.3, this may take a while depending on your cpu(s)...

ruby-1.9.3 - #fetching
ruby-1.9.3 - #downloading ruby-1.9.3-, this may take a while depending on your connection...
 % Total % Received % Xferd Average Speed Time Time Time Current
 Dload Upload Total Spent Left Speed
 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0
curl: (78) RETR response: 550
ERROR: The requested url does not exist: 'ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-.tar.bz2'
Trying http:// URL instead.
 % Total % Received % Xferd Average Speed Time Time Time Current
 Dload Upload Total Spent Left Speed
 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0Warning: Failed to create the file ruby-1.9.3-.tar.bz2: Permission denied
100 168 100 168 0 0 528 0 --:--:-- --:--:-- --:--:-- 1030
curl: (23) Failed writing body (0 != 168)
ERROR: There was an error, please check /usr/share/ruby-rvm/log/ruby-1.9.3/*.log
ERROR: There has been an error while trying to fetch the source.
Halting the installation.
ERROR: There has been an error fetching the ruby interpreter. Halting the installation.

ERROR: The requested url does not exist: ‘ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-.tar.bz2’

검색하다가, 해결방법은 찾은 듯..?

[[email protected]:~]$rails -v
Rails 4.0.0
[[email protected]:~]$ruby -v
ruby 1.9.3p448 (2013-06-27 revision 41675) [x86_64-linux]

어… 성공한 것 같긴하다.

1.2.2 Ruby, RubyGems, Rails, and Git 챕터 끝…? 뭔가 찝찝하다 -_-a

앱 & 서비스 기획자입니다. 잘하고 싶어요.

Sliding Sidebar